Лабораторная работа № 2

Моделирование нечеткой системы средствами инструментария нечеткой логики

Цель работы: изучить методы построения нечеткой системы средствами инструментария нечеткой логики (ИНЛ).

Задание для самостоятельной подготовки: изучить теоретические сведения.

Краткие теоретические сведения

Пример разработки системы нечеткого вывода в интерактивном режиме
В качестве примера разработки системы нечеткого вывода в интерактивном режиме с помощью графических средств пакета Fuzzy Logic Toolbox рассмотрим следующую нечеткую модель, которая входит в число демонстрационных примеров системы MATLAB.

Пример 1. "Чаевые в ресторане". Рассмотрим ситуацию в ресторане, при которой, согласно принятым в США традициям, после окончания обслуживания посетителя принято оставлять официанту чаевые. Основываясь на устоявшихся в этой стране обычаях и интуитивных представлениях посетителей ресторанов величина суммы чаевых не является постоянной и зависит, например, от качества обслуживания и качества приготовления заказанных блюд.
Задача состоит в том, чтобы разработать некоторую экспертную систему, которая была бы реализована в виде системы нечеткого вывода и позволяла бы определять величину чаевых на основе субъективных оценок посетителей качества обслуживания и качества приготовления заказанных блюд.
Эмпирические знания о рассматриваемой проблемной области могут быть представлены в форме следующих эвристических правил продукций:
1. Если обслуживание плохое или ужин подгоревший, то чаевые — малые.

2. Если обслуживание хорошее, то чаевые — средние.

3. Если обслуживание отличное или ужин превосходный, то чаевые — щедрые.

В качестве входных параметров системы нечеткого вывода будем рассматривать 2 нечеткие лингвистические переменные: "качество обслуживания" и "качество приготовления заказанных блюд" (или сокращенно — "качество ужина"), а в качестве выходных параметров — нечеткую лингвистическую переменную "величина чаевых".
В качестве терм-множества первой лингвистической переменной "качество обслу​живания" будем использовать множество Т1={"плохое", "хорошее", "отличное"), а в качестве терм-множества второй лингвистической переменной "качество ужина" будем использовать множество T2= {"подгоревший", "превосходный"}. В качестве терм-множества выходной лингвистической переменной "величина чаевых" будем использовать множество Тъ={"малые", "средние", "щедрые"). При этом каждый из термов первой и второй входной переменной (качество обслуживания и приго​товления заказанных блюд) будем оценивать по 10-балльной порядковой шкале, при которой цифре 0 соответствует наихудшая оценка, а цифре 10 — наилучшая оценка. Что касается термов выходной переменной, то будем предполагать, что малые чаевые составляют около 5% от стоимости заказанных блюд, средние чаевые — около 15%, а щедрые чаевые — около 25%.
С учетом сделанных уточнений, рассмотренная субъективная информация о ве​личине чаевых может быть представлена в форме 3-х правил нечетких продукций следующего вида (система нечеткого вывода типа Мамдани):
ПРАВИЛО_1: ЕСЛИ "качество обслуживания плохое" ИЛИ "ужин подгоревший"
ТО "величина чаевых малая" ПРАВИЛО_2: ЕСЛИ "качество обслуживания хорошее"
ТО "величина чаевых средняя"
ПРАВИЛО_3: ЕСЛИ "качество обслуживания отличное" ИЛИ "ужин превосходный"
ТО "величина чаевых щедрая"
Процесс разработки системы нечеткого вывода в интерактивном режиме для рассмотренного выше примера "Чаевые в ресторане" состоит в выполнении следующей последовательности действий:
1. Вызвать редактор систем нечеткого вывода FIS, для чего в окне команд набрать имя соответствующей функции fuzzy. После выполнения этой команды на экране появится графический интерфейс редактора FIS с именем системы нечеткого вывода Untitled и типом системы нечеткого вывода (Мамдани),предложенными по умолчанию.
2. Поскольку в примере 1 рассматривается система нечеткого вывода с двумя входами, необходимо добавить в разрабатываемую систему FIS еще одну входную переменную. Для этого следует выполнить команду меню Edit>Add Variable... >Input. В результате выполнения этой команды на диаграмме системы нечеткого вывода появится новый желтый прямоугольник с именем второй входной переменной: input2.

3. Изменим имена входных и выходных переменных, предложенных системой MATLAB по умолчанию. Для этого необходимо выделить прямоугольник с именем соответствующей переменной, выполнив щелчок на его изображении на диаграмме (стороны выделенного прямоугольника имеют красный цвет). После чего следует набрать новое имя переменной в поле ввода Name в правой части редактора FIS.
4.  Изменим имя системы нечеткого вывода (Untitled), предложенное по умолчанию. Для этого сохраним создаваемую структуру FIS во внешнем файле с именем mytip. fis, выполнив команду меню FiIe>Export>To Disk.... При этом будет вызвано стандартное диалоговое окно сохранения файла, в котором пользователю предлагается ввести имя соответствующего файла (расширение файла приписывается автоматически). Оставим без изменения предложенные системой MATLAB по умолчанию: метод нечеткого логического И (And method) — значение "min", метод нечеткого логического ИЛИ (Or method) — значение "max", метод импликации (Implication) — значение "min", метод аг​регирования (Aggregation)— значение "max" и метод дефаззификации (Defuzzification) — значение "centroid". Очевидно, эти значения могут быть изменены пользователем.
5. Теперь необходимо определить термы и их функции принадлежности для входных и выходных переменных нашей системы нечеткого вывода. Для этой цели следует воспользоваться редактором функций принадлежности, который может быть вызван одним из следующих способов:
 - двойным щелчком на значке прямоугольника с именем соответствующей переменной командой меню Edit>Membership Functions... (предварительно должен быть выделен прямоугольник с именем соответствующей переменной);
 - нажатием клавиш <Ctrl>+<2> (предварительно также должен быть выде​лен прямоугольник с именем соответствующей переменной).
После вызова редактора функций принадлежности каждой из переменных по умолчанию предлагается 3 терма с треугольными функции принадлежности .
Вначале изменим диапазон определения значений входных переменных, для чего в полях ввода Range и Display Range изменим верхнее значение с 1 на 10 (баллов). Аналогично выполняются изменения соответствующих диапазонов для выходной переменной "чаевые", при этом верхнее значение 1 следует заменить на 30 (%). Изменения подтверждаются нажатием на клавишу <Enter> на клавиатуре.

Далее изменим названия термов первой входной переменной "обслуживание", предложенные системой MATLAB по умолчанию (mf I, mf2, mf3) на "nwxoe", "хорошее", "типичное" соответственно. После чего изменим тип функций принадлежности первой переменной, предложенный по умолчанию, на функции типа Гаусса (gaussmf), выбрав соответствующий пункте поле Туре. Параметры вновь заданных функций принадлежности оставим без изменения. Вид редактора функций принадлежности после внесенных изменений для первой из входных переменных изображен на рис. 12.10.
Аналогичным образом изменим названия термов второй входной переменной "ужин" и удалим один из термов с соответствующей функцией принадлежности. Для удаления терма следует выделить удаляемую функцию принадлежности и нажать клавишу <Delete> на клавиатуре. Переход к редактированию переменной осуществляется щелчком на изображении прямоугольника с именем необходимой переменной. Для переменной "ужин" изменим тип функций принадлежности ее термов на трапециевидные функции (trapmf) и их параметры следующим образом: для терма "подгоревший" зададим параметры [0 0 1 3], а для терма "превосходный" — [7 9 10 10].
Наконец, изменим названия термов и параметры функций принадлежности для выходной переменной "чаевые", оставив без изменения треугольный тип функ​ций принадлежности, предложенный системой MATLAB. Для терма "малые" зададим параметры [0 5 10], а для терма "средние"— [10 15 20], для терма "щедрые" — [20 25 30].
6. Теперь настала очередь определить правила нечеткого вывода для разраба​тываемой экспертной системы. Для этой цели следует воспользоваться редактором правил, который может быть вызван одним из следующих способов:
· двойным щелчком на значке квадрата в центре с именем создаваемой сис
темы нечеткого вывода (myfis);

· командой меню Edit>Rules...;
· нажатием клавиш <Ctrl>+<3>.
Поскольку первоначально база правил нечеткого вывода пуста, то после вызова редактора правил центральное многострочное поле ввода не содержит
никаких правил. Для их определения следует использовать поля меню и переключатели в нижней части графического интерфейса редактора правил. Для задания первого правила следует оставить выделенные по умолчанию поле с именем терма "плохое" для первой входной переменной, поле с именем терма "подгоревший" для второй входной переменной и поле с именем терма "малые" для выходной переменной. Далее следует переключатель Connection поставить в положение or (логическое ИЛИ) и нажать на кнопку Add rule. После этого первое правило с символами кириллицы отобразится в верхнем окне.
Аналогичным образом задается второе правило, для которого следует выде​лить имена термов "хорошее", "попе" и "средние", и третье правило с именами термов " опчичное", "превосходный" и "щедрые" для соответствующих переменных.

Заметим, что в поле ввода Weight отображается вес каждого правила, который можно изменять в пределах интервала [0, 1] (оставим без изменения его значение по умолчанию, равное 1 для всех правил). Этот же вес правил запи​сывается в круглых скобках в окне правил после каждого из правил нечеткого вывода.
7. После задания правил нечеткого вывода оказывается возможным получить результат нечеткого вывода (значение выходной переменной) для конкретных значений входных переменных. С этой целью необходимо открыть программу просмотра правил одним из следующих способов:
· командой меню View>Rules редактора FIS;
· командой меню View>Rules редактора функций принадлежности;

· командой меню View>Rules редактора правил;

· нажатием клавиш <Ctrl>+<5>.
После вызова программы просмотра правил для нашей системы нечеткого вывода по умолчанию для входных переменных предложены средние значения из интервала их допустимых значений (значения [5 5] в поле ввода Input). Это означает, что посетитель ресторана оценивает качество обслуживания в 5 баллов и качество ужина также в 5 баллов. Этим значениям входных переменных соответствует значение чаевых в 15%, которое отображается выше прямоугольников правил в правой части окна программы просмотра.
Изменим значения входных переменных для другого случая, которому соответствует качество обслуживания в 0 баллов ("хуже некуда") и качество ужина в 10 баллов ("лучше не бывает"). Для этого курсор мыши переместим в поле ввода Input и введем соответствующие значения входных переменных: [0 10]. Система MATLAB оставит значение чаевых без изменения (15%), однако на диаграмме правил можно заметить результаты выполненных изменений (рис. 12.14).
Поскольку процесс нечеткого моделирования предполагает анализ результатов нечеткого вывода при различных значениях входных переменных с целью установления адекватности разработанной нечеткой модели (в данном случае— экспертной системы), рассмотрим и другие случаи. Предположим, что качество обслуживания оценивается в 10 баллов ("лучше не бывает"), а качество ужина — в 2 балла ("бывает и хуже, но реже"). Введем соответствующие значения переменных аналогичным способом. В этом случае разработанная система нечеткого вывода рекомендует нам оставить чаевые в размере 16.4%.
Если же предположить, что качество обслуживания по-прежнему отличное (10 баллов), а качество ужина несколько улучшилось и оценивается в 3 балла, то величина чаевых существенно изменится и станет равной 24.7%. Более того, дальнейшее увеличение качества ужина не оказывает изменения величины чаевых. В частности, для значений входных переменных [10 10] величина чаевых составит по-прежнему 24.7%. Если некоторым из посетителей такая экспертная система покажется неадекватной (в частности, для случая значений входных переменных [10 10] можно бы оставить максимальные чаевые в 30%), то разработанная система нечеткого вывода потребует модификации. Данная модификация может потребовать изменения существующих правил или добавления новых, а также изменения параметров функций принадлежности
входных и выходной переменных. Более тонкая настройка модели может быть связана с увеличением количества термов для каждой из входных и выходных переменных, что, в свою очередь, приведет к увеличению количества правил в системе нечеткого вывода и общему усложнению модели 

Для окончательного анализа разработанной нечеткой модели может оказаться полезной программа просмотра поверхности нечеткого вывода, которая мо​жет быть вызвана одним из следующих способов:
· командой меню View>Surface редактора FIS;
· командой меню View>Surface редактора функций принадлежности;

· командой меню View>Surface редактора правил;

· командой меню View>Surface программы просмотра правил;

· нажатием клавиш <Ctrl>+<6>.
Рекомендации к выполнению:

1. Вызовите редактор систем нечеткого вывода FIS, указав в командной строке команду fuzzy.

2. Ознакомьтесь с графическим интерфейсом редактора FIS.

3. Определите все компоненты редактора FIS.
4. Выполните  приведенный пример.
5. Определите предметную область для разработки  нечеткой модели.
6. Определите входные переменные и выходные.

7. Обоснуйте выбор функций принадлежности для каждой переменной.

8. Разработайте правила для системы нечеткого вывода.

9. Реализуйте в системе Matlab вашу нечеткую модель для выбранной предметной области.
10. На основе определенных универсумов сформировать нечеткие отношения. Выполнить композицию бинарных отношений.

Контрольные вопросы
1. Сформулируйте определение редактора систем нечеткого вывода FIS.
2. Перечислите возможности вызова редактора FIS. 
3. Сформулируйте определение редактора функций принадлежности

4. Укажите возможности вызова редактора функций принадлежности.
5. Каким образом можно добавить(удалить) встроенную функцию принадлежности термов для выбранной переменной.
6. Сформулируйте назначение редактора правил систем нечеткого вывода.

7. Перечислите возможности вызова редактора правил систем нечеткого вывода. 
